bugrdiff-backup - Bugs: bug #17625, Problem with mounted file systems

 
 

bug #17625: Problem with mounted file systems

Submitted by:  Michael Stucki <stucki>
Submitted on:  Wed 06 Sep 2006 12:58:51 PM UTC  
 
Category:  None Severity:  3 - Normal
Item Group:  None Status:  Duplicate
Privacy:  Public Assigned to:  None
Open/Closed:  Closed

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 05 Nov 2006 01:40:08 AM UTC, comment #1: 

search the mailing list for information about temp files... rdiff-backup creates temporary files while it works -- and this is probably the source of what you're seeing.

i'm closing out the bug because this is a "known problem"... actually i think there may even be a patch for it, but i have lots of mail to catch up on.

dean gaudet <dgaudet>
Project Administrator
Wed 06 Sep 2006 12:58:51 PM UTC, original submission:  

Hi,

today I discovered a problem which I suppose is a bug in rdiff-backup:

I have a server that uses LVM (logical volume manager) and has several logical volumes mounted in:

/dev/sda5 on / type ext3
/dev/mapper/volgroup1-tmp on /tmp type ext3
/dev/mapper/volgroup1-var on /var type ext3
/dev/mapper/volgroup1-backup--tmp on /var/backups type ext3

Notice that rdiff-backup will be called inside /var/backups/rdiff-backup.

Now when running rdiff-backup, it occured several times that the volume ran out of space, although /var/backups has more than 70G free.

While reproducing the problem again and again, I watched using "df" and "du" to see where the space is assigned.

Apparently it seems that /var is shrinking more and more, but no files are created ("du" writes the same sizes all the time).

Could it be that rdiff-backup is writing the (yet incomplete) data to /var because it doesn't notice that /var/backups/rdiff-backup is on another volume?

Michael Stucki <stucki>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

CC list is empty

 

Do you think this task is very important?
If so, you can add your encouragement to it.
This task has 0 encouragements so far.

Only logged-in users can vote.

 

 

 

Follow 2 latest changes.

Date Changed by Updated Field Previous Value => Replaced by
2006-11-05 dgaudet StatusNone => Duplicate
    Open/ClosedOpen => Closed

Back to the top


Powered by Savane 3.5