bugAVR C Runtime Library - Bugs: bug #26365, Better PROGMEM_FAR support

 
 

bug #26365: Better PROGMEM_FAR support

Submitted by:  Jan Waclawek <wek>
Submitted on:  Mon 27 Apr 2009 09:47:19 PM UTC  
 
Category:  Feature Request Severity:  3 - Normal
Priority:  5 - Normal Item Group:  None
Status:  Duplicate Assigned to:  Eric Weddington <arcanum>
Percent Complete:  0% Open/Closed:  Closed
Release:  Any Fixed Release:  None

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Mon 14 Jun 2010 11:21:58 AM UTC, comment #6: 

In attachment, pgmspace.h and an example linker script (avr6).
Changes in pgmspace.h against http://svn.savannah.nongnu.org/viewvc/trunk/avr-libc/include/avr/pgmspace.h?revision=2168&root=avr-libc&view=markup :
- documentation related to PROGMEM_FAR and PROGMEM_SEGX added - I don't doxygen so please fix formal errors
- pgm_read_xxx_seg1() macros are now defined for the xmega with RAMPD and m103 too
- minor tweak in PSXSTR macros - the optimizer copes better with | than +

JW

(file #20748)

Jan Waclawek <wek>
Sat 22 May 2010 02:44:44 PM UTC, comment #5: 

No patches which could be added with no effort from the side of project maintainers, yet (and zero likelihood of them ever); but for those who are interested, some of my solutions of the items below are now posted here.

JW

Jan Waclawek <wek>
Tue 28 Apr 2009 07:32:17 AM UTC, comment #4: 

What is then the appropriate form of posting feature requests, which are not likely to be implemented immediately, but still might be an inspiration for anybody who has time to pick up older ideas in the future?

My naive idea was, that feature request is intended exactly for this...

JW

Jan Waclawek <wek>
Tue 28 Apr 2009 07:25:40 AM UTC, comment #3: 

> Shall I submit it as a series of feature requests, rather?


I'm afraid nobody will have the time to really implement that
unless you're accompanying it with patches.

Joerg Wunsch <joerg_wunsch>
Project Administrator
Tue 28 Apr 2009 07:19:29 AM UTC, comment #2: 

I beg to differ.

The request is a list, of which only the first item is duplicate of patch #6352.

Shall I submit it as a series of feature requests, rather?

JW

Jan Waclawek <wek>
Tue 28 Apr 2009 07:07:27 AM UTC, comment #1: 

Patch #6352 will be added to avr-libc before the next release.

Closing this feature request as a duplicate of patch #6352.

Eric Weddington <arcanum>
Project AdministratorIn charge of this item.
Mon 27 Apr 2009 09:47:19 PM UTC, original submission:  

It would be nice to see a better support for constant variables placed above the 64kB limit in those AVRs which do have >64kB FLASH.

This could include one or more of the following:
- inclusion of complete https://savannah.nongnu.org/patch/?6352 of Carlos Lamas, especially the GET_FAR_ADDRESS() macro
- similar macros for far function pointers, if possible
- a section to the relevant default linker scripts, placed just above the end of code (.fini0) - maybe called .progmem_far
- a macro hiding usage of the above section, maybe as PROGMEM_FAR, analogous to the existing PROGMEM macro
- detection of crossing of the 64kB boundary by PROGMEM variables (and other related data which needs to be positioned at the bottom 64kB)
- better detection of big PROGMEM data initialiser - at the moment, the compiler throws an error if the initialiser is >32kB, but compiles cleanly (albeit incorrectly) if the initialiser is >64kB.

Thanks,

Jan Waclawek

Jan Waclawek <wek>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #20748:  pgmspace.zip added by wek (9KiB - application/zip)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by joerg_wunsch (Posted a comment)
  • -email is unavailable- added by arcanum (Posted a comment)
  • -email is unavailable- added by wek (Submitted the item)
  •  

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2010-06-14 wek Attached File- => Added pgmspace.zip, #20748
    2009-04-28 arcanum StatusNone => Duplicate
        Assigned toNone => arcanum
        Open/ClosedOpen => Closed

    Back to the top


    Powered by Savane 3.5