bugMapOSMatic - Bugs: bug #28700, Add path, footway, cycle lane and...

 
 

bug #28700: Add path, footway, cycle lane and cycleway to render

Submitted by:  Thomas Clavier <tomDouze>
Submitted on:  Thu 21 Jan 2010 08:56:13 AM UTC  
 
Category:  ocitysmap Severity:  3 - Normal
Priority:  5 - Normal Status:  Duplicate
Privacy:  Public Assigned to:  David Mentré <dmentre>
Open/Closed:  Closed Release:  None

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Tue 14 Sep 2010 12:09:33 PM UTC, comment #8: 

For me it's cover by #9687. You can close it.

Thomas Clavier <tomDouze>
Tue 11 May 2010 03:03:52 PM UTC, comment #7: 

David M., what's the final word on this? It was my understanding too that paths, footways and cycleways were already rendered at the level 16 we're using. So is it a confirmed bug or not?

Maxime Petazzoni <mpetazzoni>
Project Administrator
Mon 08 Feb 2010 09:19:39 PM UTC, comment #6: 

Sorry Thomas for the delay. You should be able to post comments on task #9687.

David Mentré <dmentre>
Project AdministratorIn charge of this item.
Wed 03 Feb 2010 08:20:42 AM UTC, comment #5: 

but i can't post comment on #9687 ....

Thomas Clavier <tomDouze>
Wed 03 Feb 2010 08:17:36 AM UTC, comment #4: 

ok, you can close it

Thomas Clavier <tomDouze>
Tue 02 Feb 2010 08:38:56 PM UTC, comment #3: 

Definitely, task #9687 should be extended to cover the generic topic of « let the user specify an alternate render file », be it a predefined file or a user-provided file.

Thomas Petazzoni <tpetazzoni>
Project Administrator
Thu 21 Jan 2010 01:03:56 PM UTC, comment #2: 

the default mapnik doesn't render cycle lane ... and cycleway was render under highway :-(

For example :
- http://www.openstreetmap.org/?lat=50.68312&lon=3.17016&zoom=16&layers=00B0FTF
- http://www.openstreetmap.org/?lat=50.68312&lon=3.17016&zoom=16&layers=B000FTF

about #9687, in my opinion, upload an xml render file it's a good idea but it's not easy for all users. In my request, i suggest to just change the default render car's dedicated to a pedestrian or cyclists render. If you prefer propose 2 our 3 different render in addition of ability to upload xml configuration files, i thinks it's a good idea. If you thinks this idea is the same than #9687 you can close this bug and i can add my comment in the other bug.

Thomas Clavier <tomDouze>
Thu 21 Jan 2010 09:15:22 AM UTC, comment #1: 

Hello Thomas,

We are doing rendering at zoom level 16 which already renders cycleway, footway and paths.

Currently, the generated maps are made for any usage and we are using default rendering style from openstreetmap.org.

Some people have requested to add capability to change the rendering style and we have opened a task for that:
  https://savannah.nongnu.org/task/?9687

So I would consider this request a duplicate of above task and close this bug as Duplicate.

David Mentré <dmentre>
Project AdministratorIn charge of this item.
Thu 21 Jan 2010 08:56:13 AM UTC, original submission:  

Hello,

In my opinion, paper city map will be primarily used by pedestrians and cyclists. To facilitate this usage, it would be nice to highlight the cycleway, footway and paths ?

Thomas Clavier <tomDouze>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mpetazzoni (Posted a comment)
  • -email is unavailable- added by tpetazzoni (Posted a comment)
  • -email is unavailable- added by dmentre (Posted a comment)
  • -email is unavailable- added by tomDouze (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2010-09-14 mpetazzoni CategoryNone => ocitysmap
        StatusNeed Info => Duplicate
        Open/ClosedOpen => Closed
    2010-05-11 mpetazzoni Assigned toNone => dmentre
    2010-01-21 dmentre StatusNone => Need Info

    Back to the top


    Powered by Savane 3.7