buggNewSense GNU/Linux - Bugs: bug #28893, Konqueror sends OpenDocument...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #28893: Konqueror sends OpenDocument Format files to Okular which then crashes

Submitted by:  Lars Noodén <larsnooden>
Submitted on:  Sun 14 Feb 2010 10:27:40 AM UTC  
 
Category: PackageSeverity: 3 - Normal
Item Group: amd64Status: Fixed
Privacy: PublicAssigned to: None
Open/Closed: Closed

Fri 12 Jul 2013 05:05:41 PM UTC, comment #2:

The link in the original submission is dead, but the attachment at the KDE bug report works fine with Okular in Parkes.

Sam Geeraerts <samgee>
Project Administrator
Mon 01 Mar 2010 10:37:04 AM UTC, comment #1:

It looks like an Okular bug. Starting it and opening a local copy of the linked file crashes Okular in metad i386. This is possibly KDE bug #168678 - https://bugs.kde.org/show_bug.cgi?id=168678 Backtrace and other gdb output are attached.

(file #19826, file #19827)

Eric Padman <mentalnotes>
Sun 14 Feb 2010 10:27:40 AM UTC, original submission:

http://sv.openoffice.org/files/documents/213/4704/file_4704.dat/Installation_Guide_OOo3 översättning 100118.odt

1) Go to URL above

2 Answer "Open with 'Okular'" to the dialog given:

Open 'http://sv.openoffi...ättning 100118.odt'?
Type: OASIS OpenDocument Text

3) Watch it crash

A Fatal Error Occurred
The application Okular (okular) crashed and caused the signal 6 (SIGABRT).
Please help us improve the software you use by filing a report at http://bugs.kde.org. Useful details include how to reproduce the error, documents that were loaded, etc.

4) Generate second error by choosing 'Show Details'

Could not generate a backtrace as the debugger 'gdb' was not found.

Expected result: opening any file of the MIME Types matching

application/vnd.oasis.opendocument.*

should open correctly in Okular or another viewer capable of at least rendering ODF. Perhaps it is incorrect default settings in Konqueror that send the file to Okular.

$ apt-cache policy okular
okular:
Installed: 0.7-2
Candidate: 0.7-2
Version table:

      • 0.7-2 0

500 http://archive.gnewsense.org metad/main Packages
100 /var/lib/dpkg/status

$ apt-cache policy konqueror
konqueror:
Installed: 4:3.5.9.dfsg.1-6
Candidate: 4:3.5.9.dfsg.1-6
Version table:

      • 4:3.5.9.dfsg.1-6 0

500 http://archive.gnewsense.org metad/main Packages
100 /var/lib/dpkg/status

$ lsb_release -rd
Description: gNewSense GNU/Linux 3.0 (metad)
Release: 3.0

Lars Noodén <larsnooden>

 

Attached Files

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by samgee (Posted a comment)
  • -unavailable- added by mentalnotes (Updated the item)
  • -unavailable- added by larsnooden (Submitted the item)
  •  

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 4 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Fri 12 Jul 2013 05:05:41 PM UTCsamgeeStatusNone=>Fixed
      Open/ClosedOpen=>Closed
    Mon 01 Mar 2010 10:37:04 AM UTCmentalnotesAttached File-=>Added okular-backtrace.txt, #19826
      Attached File-=>Added okular-other-gdb-output.txt, #19827

    Back to the top


    Powered by Savane 3.1-cleanup