buggNewSense GNU/Linux - Bugs: bug #29573, ltsp-server chokes on nbd-server...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #29573: ltsp-server chokes on nbd-server configuration

Submitted by:  Lars Noodén <larsnooden>
Submitted on:  Fri 16 Apr 2010 09:00:30 AM UTC  
 
Category: gNewSense 3Severity: 3 - Normal
Item Group: i386Status: Fixed
Privacy: PublicAssigned to: None
Open/Closed: Closed

Fri 12 Jul 2013 05:39:50 PM UTC, comment #3:

No message about LSB when installing ltsp-server on Parkes. No message about ucf when running dpkg-reconfigure nbd-server on Parkes.

Sam Geeraerts <samgee>
Project Administrator
Mon 03 May 2010 10:09:45 AM UTC, comment #2:

All of those messages look like warnings. For example, if you have to create the config file before running the service, its entirely reasonable for it not to find one.
Since the install appears to continue anyway, I'm not sure what the bug is here.

Karl Goetz <kgoetz>
Fri 16 Apr 2010 09:17:17 AM UTC, comment #1:

This appears to be specifically the package nbd-server

$ apt-cache policy nbd-server
nbd-server:
Installed: 1:2.9.11-3
Candidate: 1:2.9.11-3
Version table:

      • 1:2.9.11-3 0

500 http://archive.gnewsense.org metad/main Packages
100 /var/lib/dpkg/status

running dpkg-reconfigure manually also gives this other error:

      • WARNING: ucf was run from a maintainer script that uses debconf, but the script did not pass --debconf-ok to ucf. The maintainer script should be fixed to not stop debconf before calling ucf, and pass it to this parameter. For now, ucf will revert to using old-style, non-debconf prompting. Ugh!

Please inform the package maintainer about this problem.

Lars Noodén <larsnooden>
Fri 16 Apr 2010 09:00:30 AM UTC, original submission:

The meta package ltsp-server chokes on nbd-server installation at the configuration step:

update-rc.d: warning: /etc/init.d/nbd-server missing LSB information
update-rc.d: see <http://wiki.debian.org/LSBInitScripts>

    • (process:5402): WARNING **: Could not parse config file: Could not open config file.
    • Message: Nothing to do! Bye!

nbd-server.
Setting up nfs-kernel-server (1:1.1.2-6lenny1) ...

Creating config file /etc/exports with new version

$ apt-cache policy ltsp-server
ltsp-server:
Installed: 5.1.10-2
Candidate: 5.1.10-2
Version table:

      • 5.1.10-2 0

500 http://archive.gnewsense.org metad/main Packages
100 /var/lib/dpkg/status

Lars Noodén <larsnooden>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by samgee (Posted a comment)
  • -unavailable- added by larsnooden (Submitted the item)
  •  

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Fri 12 Jul 2013 05:39:50 PM UTCsamgeeStatusNeed Info=>Fixed
      Open/ClosedOpen=>Closed
    Mon 03 May 2010 10:09:53 AM UTCkgoetzStatusNone=>Need Info

    Back to the top


    Powered by Savane 3.1-cleanup