bugWeeChat - Bugs: bug #31089, Crash when loading plugin

 
 

bug #31089: Crash when loading plugin

Submitter:  None
Submitted:  Mon 20 Sep 2010 07:46:29 PM UTC
 
Category:  plugins Severity:  3 - Normal
Item Group:  crash Status:  Invalid
Privacy:  Public Assigned to:  flashcode
Originator Name:  Leon Bogaert Originator Email:  * -email is unavailable-
Open/Closed:  Closed Release:  * 0.3.3
IRC nick:  LBo
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       No canned response available

 

Tue 21 Sep 2010 12:01:21 PM UTC, comment #4: 

WeeChat is mono-threads. Threads are forbidden in plugins or scripts. If you want to have another process (with fork), use hook_process in API.
This is not a bug, this is mono-thread by design ;)

Sebastien Helleu <flashcode>
Project Administrator
Tue 21 Sep 2010 11:57:09 AM UTC, comment #3: 

I've created a minimal python script that makes weechat crash.
Running it from the commandline works

#import gobject
#gobject.threads_init()
#import weechat
import threading

#weechat.register("windicate", "Leon Bogaert", "0.0.1", "GPL",
#                 "fills the indicator applet", "", "")

def do_something():
    print "Doing something"

threading.Thread(target=do_something).start()

Anonymous
Mon 20 Sep 2010 09:55:40 PM UTC, comment #2: 

OK. If it's not a bug it can be closed.

Thanks for the response!

Anonymous
Mon 20 Sep 2010 08:47:10 PM UTC, comment #1: 

WeeChat can crash if your plugin does something illegal, this is not a bug, this is because WeeChat does minimum checks on plugin calls to API (for fast execution of plugins).

Please tell me which plugin is causing problem.

And I need backtrace with gdb, please look at documentation for info on gdb and crash reports.

Sebastien Helleu <flashcode>
Project Administrator
Mon 20 Sep 2010 07:46:29 PM UTC, original submission:  

I thought to work on an old plugin I never finished. But when I try to load this plugin now, weechat crashes :(

In the past this plugin loaded just fine. I've tried weechat 0.3.2 and 0.3.3

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #21510:  weechat_crash_20100920_11928.log.tar.bz2 added by None (45KiB - application/x-bzip)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by flashcode (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2011-01-16 flashcode Open/ClosedOpen Closed
    2010-09-21 flashcode StatusNeed Info Invalid
    2010-09-20 flashcode StatusNone Need Info
        Assigned toNone flashcode
    2010-09-20 None Attached File- Added weechat_crash_20100920_11928.log.tar.bz2, #21510

    Back to the top


    Powered by Savane 3.9