bugWeeChat - Bugs: bug #33186, random crashes after a few hours...

 
 

bug #33186: random crashes after a few hours running

Submitter:  Bill <teknowill>
Submitted:  Fri 29 Apr 2011 09:24:14 PM UTC
 
Category:  None Severity:  3 - Normal
Item Group:  crash Status:  Wont Fix
Privacy:  Public Assigned to:  flashcode
Originator Name:  Open/Closed:  Closed
Release:  * 0.3.4 IRC nick:  teknowill
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       No canned response available

 

( Jump to the original submission )

Sun 01 May 2011 04:27:13 PM UTC, comment #6: 

Then I'll close this bug.

And by the way, I recommend you to use the -dbg package and enable core files, so that in case of crash you'll be able to send me the gdb backtrace.
Thank you!

PS: I'm using Debian, so I can't tell you why ubuntu has so old version (in debian stable there is 0.3.2 and in backports 0.3.4).

Sebastien Helleu <flashcode>
Project Administrator
Sun 01 May 2011 04:11:33 PM UTC, comment #5: 

Hi, again sorry to waste your time on an older version.

I understood, but it was all I had to go on as well, wasn't on the pc when it crashed, was just hoping details/log would have helped in some way. i.e. over time one could see a pattern.

Anyway, I've had weechat 0.3.4-1 (for real this time) running nonstop since my last post with debug binary and it hasn't crashed, so I think you can close this as an Ubuntu repository and/or pebcak/ID-10T error.

Out of curiosity why is Ubuntu's repository so old/slow to change looks you had a 0.3.0 out almost 1.5 years ago? I know why Debian does this, but at least when they muck about in your code it works...

Thanks again,
Bill

Bill <teknowill>
Sun 01 May 2011 07:39:34 AM UTC, comment #4: 

Yes, please only report bugs for latest stable version, or devel version.

And by "way to reproduce", I mean some actions that lead to crash immediately. Not "wait and it will crash after a few hours".
So if you don't have a gdb trace, or a way to reproduce, I'll fix this bug (as I said you can still open another later with the gdb trace, which is better info for me to fix bug).

Sebastien Helleu <flashcode>
Project Administrator
Sat 30 Apr 2011 06:17:37 PM UTC, comment #3: 

need to make correction:

using binary:
0.3.0-2ubuntu1

all problems may be invalid as ubuntu binary is old. will see if newer binaries are better. Sorry about he mix up.

Bill <teknowill>
Sat 30 Apr 2011 06:11:58 PM UTC, comment #2: 

yeah, sorry. I tried gdb before, but as I didn't have dbg .deb binary it didn't work. was just trying to give heads up as I might have been doing something that weechat shouldn't do and was easy to spot.

I will try to reproduce the crash.

more info about what I was doing, in-order to reproduce:

running:
Ubuntu 10.04 amd64 on sony laptop (VGN-SZ780) - nvidia 8400GT
installed: weechat lucid binary 0.3.4-1
installed: minbif lucid binary 1.0.1 from Ubuntu repository
have buffers.pl in autostart

start weechat-curses  in gnome-terminal full screen
in weechat:
enter:
/alias map /quote map (allows adding of logins for minbif)
/map add jabber -email is unavailable- password &gtalk
/map add jabber -email is unavailable- password &facebook
have a incorrect add --- this may be the cause...
/map add aim -email is unavailable- password -port 5190 &aim
fix it, but don't remove bad one
/map add aim    user password &aim
/connect Ubuntu
/J ubuntu (if not in channel by default)
exit weechat
add attached facebook_rename.py and im_typing_notice.rb to autostart
open weechat-curses
let it run...

hope that helps a bit,
Bill

(file #23331, file #23332)

Bill <teknowill>
Sat 30 Apr 2011 07:04:01 AM UTC, comment #1: 

Hi,

This crash log file is not enough to fix problem (it would be enough only if you are able to tell me exactly how to reproduce crash).
So, please recompile WeeChat with debug and get a trace with gdb, like explained in doc:
http://weechat.org/files/doc/devel/weechat_user.en.html#report_crashes

If you are not able to reproduce crash, then I'll close this bug, and you can file another bug later if you have a similar crash (or if you know how to reproduce it).

Thank you.

Sebastien Helleu <flashcode>
Project Administrator
Fri 29 Apr 2011 09:24:14 PM UTC, original submission:  

Hi,

everything sees to work fine, ran for about 5 hours but it crashed. is a problem as I don't know if people sent me a msg and have friends in different timezones that might have...
not doing anything special I was asleep.

I don't think this is the scripts as they carry out the jobs with out a crash.

I really like your program hope you can help.

connected to #ubuntu irc
connected to localhost minbif 1.0.1: aim jabber:googletalk facebook
using scripts: buffers, facebook_rename.rb
Ubuntu 10.04x64

I split the crash log into 3 parts, was too big.

Thanks for you help,
-Bill

Bill <teknowill>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #23331:  facebook_rename.py added by teknowill (4KiB - text/x-python)
file #23332:  im_typing_notice.rb added by teknowill (4KiB - application/x-ruby)
file #23326:  xab added by teknowill (500KiB - application/octet-stream)
file #23325:  xac added by teknowill (344KiB - application/octet-stream)
file #23324:  xaa added by teknowill (500KiB - application/octet-stream)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by flashcode (Posted a comment)
  • -email is unavailable- added by teknowill (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

     

     

     

    Follow 9 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2011-05-01 flashcode StatusNeed Info Wont Fix
        Open/ClosedOpen Closed
    2011-04-30 teknowill Attached File- Added facebook_rename.py, #23331
        Attached File- Added im_typing_notice.rb, #23332
    2011-04-30 flashcode StatusNone Need Info
        Assigned toNone flashcode
    2011-04-29 teknowill Attached File- Added xab, #23326
    2011-04-29 teknowill Attached File- Added xac, #23325
    2011-04-29 teknowill Attached File- Added xaa, #23324

    Back to the top


    Powered by Savane 3.9