bugGChemPaint - Bugs: bug #34947, position in 'text' field lost...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #34947: position in 'text' field lost after closing the file

Submitted by:  Tomasz Borowski <tiron>
Submitted on:  Wed 30 Nov 2011 10:16:34 AM UTC  
 
Category:  None Severity:  3 - Normal
Item Group:  None Status:  Fixed
Privacy:  Public Assigned to:  Jean Bréfort <jean_brefort>
Open/Closed:  Closed

Wed 27 Feb 2013 07:40:45 AM UTC, comment #4:

Fixed for long.

Jean Bréfort <jean_brefort>
Project AdministratorIn charge of this item.
Wed 30 Nov 2011 08:46:22 PM UTC, comment #3:

Fixed in both branches.

Jean Bréfort <jean_brefort>
Project AdministratorIn charge of this item.
Wed 30 Nov 2011 08:21:09 PM UTC, comment #2:

Oops, I see what happens. Will be fixed shortly.

Jean Bréfort <jean_brefort>
Project AdministratorIn charge of this item.
Wed 30 Nov 2011 10:26:37 AM UTC, comment #1:

Quite strange indeed. Can you attach sample files? I mean a screenshot before saving and the saved file. I have seen some cases where the whole text is moved (but hardly reprducible, unfortunately), but not cases where only superscripts/subscripts are misplaced.

Btw, you can get H2O and H+ with the element tool too. An oxygen without bond will be displayed H2O (with the default position for the H atoms). For H+, add you get HH, and then you can set the charge to + with the appropriate tool.

Jean Bréfort <jean_brefort>
Project AdministratorIn charge of this item.
Wed 30 Nov 2011 10:16:34 AM UTC, original submission:

Dear Developers,

I just started to use GChemPaint (0.12.8) (as an alternative
to ChemDraw) and I like it. However, I encountered
two problems:

1) when I saved and closed a file with e.g. 'H2O' text field with '2' positioned approprietly for a water molecule, and re-opened it
the position of '2' changed from -9 to -100. I observed a similar behavior for 'H+', but then the position changed from '9' to '100'

2) when I saved any structure as a svg figure, and then tried to edit it in Inkscape, the file opened properly, yet when saving it as an eps file all atomic symbols (fonts) were lost.

Tomasz Borowski <tiron>

 

Attached Files

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by tiron (Submitted the item)
  • -email is unavailable- added by tiron
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 7 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2013-02-27 jean_brefort Open/ClosedOpen => Closed
    2011-11-30 jean_brefort StatusNeed Info => Fixed
    2011-11-30 tiron Attached File- => Added Screenshot at 2011-11-30 20:39:23.png, #24508
        Attached File- => Added Screenshot at 2011-11-30 20:40:33.png, #24509
    2011-11-30 jean_brefort StatusNone => Need Info
        Assigned toNone => jean_brefort
    2011-11-30 tiron Carbon-Copy- => Added tiron

    Back to the top


    Powered by Savane 3.3