bugWeeChat - Bugs: bug #36559, Unable to print characters wider...

 
 

bug #36559: Unable to print characters wider than monospace

Submitted by:  Daniel Wallace <gtmanfred>
Submitted on:  Tue May 29 15:08:13 2012  
Votes:  1  
 
Category: displaySeverity: 3 - Normal
Item Group: displayStatus: Invalid
Privacy: PublicAssigned to: Sebastien Helleu <flashcode>
Originator Name: Open/Closed: Closed
Release: 0.3.8IRC nick: gtmanfred

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat Jul 20 06:06:51 2013, comment #4:

For me the bug is in ncurses, not WeeChat.

You can check with this test program: http://weechat.org/files/temp/c/curses.c (instructions to compile in the file).

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Thu Mar 7 09:04:43 2013, comment #3:

The same exact problem seems to occurr with zero width spaces (like U+200B).

See the following test script:
https://gist.github.com/stfnm/c8597a41301a93a03a9b

stfn <stfn>
Wed Feb 20 21:34:32 2013, comment #2:

Hey there,

I just noticed that the unicode card deck symbols aren't displayed, also, when they're in a message, they cause the message to be cut off at that position.

You can find these symbols here: http://en.wikipedia.org/wiki/Playing_cards_in_Unicode#Playing_cards_deck
The card suits are just working fine.

Example:
Message is "Look at this:

Richard Schwab <nothing4you>
Sat Jun 9 07:02:48 2012, comment #1:

Problem is not exactly this one, because most of wide chars (more than one char on screen) are working fine in WeeChat, for example japanese chars.

The problem is with some chars like this one:
http://www.fileformat.info/info/unicode/char/1f638/index.htm
I made some tests with a basic ncurses app and I was unable to display such char on screen (looks like the UTF-8 sequence is not recognized by ncurses).
Then could you please report problem to ncurses team, to check if it's a problem with ncurses or not?

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Tue May 29 15:08:13 2012, original submission:

I am unable to see characters such as u1f638 and other characters that are 2 or more characters in width in weechat. I am using a recently compiled git version

Daniel Wallace <gtmanfred>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by stfn (Posted a comment)
  • -unavailable- added by nothing4you (Posted a comment)
  • -unavailable- added by nothing4you (Voted in favor of this item)
  • -unavailable- added by flashcode (Updated the item)
  • -unavailable- added by gtmanfred (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 1 encouragement so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 6 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun Oct 6 07:43:32 2013flashcodeOpen/ClosedOpen=>Closed
    Sat Jul 20 06:06:51 2013flashcodeStatusNeed Info=>Invalid
    Wed Feb 20 21:34:32 2013nothing4youCarbon-Copy-=>Added nothing4you
    Sat Jun 9 07:02:48 2012flashcodeStatusNone=>Need Info
      Assigned toNone=>flashcode
    Sun Jun 3 08:24:02 2012flashcodeRelease1.7-dev=>0.3.8

    Back to the top


    Powered by Savane 3.1-cleanup