bugBos Wars - Bugs: bug #40645, boswars should compile with Lua 5.2

 
 

bug #40645: boswars should compile with Lua 5.2

Submitted by:  Paul Dufresne <pauld>
Submitted on:  Wed 20 Nov 2013 12:30:10 AM UTC  
 
Severity:  3 - Normal Item Group:  Feature Request
Status:  None Privacy:  Public
Assigned to:  None Open/Closed:  Open

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 09 Feb 2014 12:57:33 PM UTC, comment #2:

There's often grass in the battefield. Sometimes sand or rocks, but not black matter. Does it work now ? Did you try with OpenGL disabled ?

Fran├žois Beerten <feb>
Project Administrator
Wed 20 Nov 2013 01:23:50 AM UTC, comment #1:

Sorry, but current PKGBUILD file in ArchLinux AUR is getting an old revision: 10083.

By changing the line from:
pkgver=10083
to:
pkgver=10225

before issueing makepkg command, I am now able to build the package fine and play with it.

My only surprise is the black background... was remembering grass.

Paul Dufresne <pauld>
Wed 20 Nov 2013 12:30:10 AM UTC, original submission:

I am/was trying to compile boswars on Arch Linux with AUR package at: https://aur.archlinux.org/packages/boswars-svn/

I get:
======
At revision 10083.
g++ -c engine/stratagus/script.cpp -o fbuild/release/script.o -Wall -fsigned-char -D_GNU_SOURCE=1 -D_REENTRANT -I/usr/include/SDL -DHAVE_STRCASESTR -DHAVE_STRNLEN -DHAVE_X -Iengine/include -Iengine/guichan/include -DUSE_VORBIS -DUSE_THEORA -DUSE_OGG -O2
engine/stratagus/script.cpp: In function 'int luatraceback(lua_State*)':
engine/stratagus/script.cpp:148:18: error: 'LUA_GLOBALSINDEX' was not declared in this scope
lua_gettable(L, LUA_GLOBALSINDEX);
^
engine/stratagus/script.cpp: In function 'char* SaveGlobal(lua_State*, bool)':
engine/stratagus/script.cpp:1032:19: error: 'LUA_GLOBALSINDEX' was not declared in this scope
lua_gettable(l, LUA_GLOBALSINDEX);
^
engine/stratagus/script.cpp: In function 'void SavePreferences()':
engine/stratagus/script.cpp:1188:20: error: 'LUA_GLOBALSINDEX' was not declared in this scope
lua_gettable(Lua, LUA_GLOBALSINDEX);
^
fabricate: 'g++' exited with status 1
=====

http://lists.opensuse.org/opensuse-factory/2012-01/msg00265.html suggest that it could be because boswars need lua5.1 not lua5.2

Fedora seems to have applied the following patch to build with Lua 5.2:
http://web.archiveorange.com/archive/v/NUQmuzfEW27NeGJ82aVD

Probably, a good fix would change the function detectLua in make.py, and would detect if the system have Lua 5.1, 5.2 or both, and define some symbols, to allow building the program in the two cases.

That said, I don't feel I know enough to make such a contribution.

Paul Dufresne <pauld>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by feb (Posted a comment)
  • -email is unavailable- added by pauld (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    No changes have been made to this item

    Back to the top


    Powered by Savane 3.3