bugrdiff-backup - Bugs: bug #46205, rdiff-backup fails with Invalid...

 
 

bug #46205: rdiff-backup fails with Invalid argument

Submitted by:  None
Submitted on:  Wed 14 Oct 2015 06:58:08 AM UTC  
 
Category:  None Severity:  2 - Minor
Item Group:  None Status:  Duplicate
Privacy:  Public Assigned to:  None
Open/Closed:  Closed

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 24 Feb 2020 03:52:11 PM UTC, comment #3: 

Duplicate of https://github.com/rdiff-backup/rdiff-backup/issues/11 and/or https://github.com/rdiff-backup/rdiff-backup/issues/38 - rdiff-backup has definitely some limitations when it comes from backing up files from one file system to another one with less features. We'll look into it once the code is cleaner.

Eric L. <ericzolf>
Project Administrator
Fri 12 Feb 2016 08:55:58 AM UTC, comment #2: 

filesystem quoting on this filesystem is not well supported. Once we get python3 support working everything will change. postponing for now.

david kempe <davekempe>
Project Administrator
Wed 14 Oct 2015 06:59:32 AM UTC, comment #1: 

Moreover: the filesystem for source data is ext4.

The target filesystem is VFAT.

Anonymous
Wed 14 Oct 2015 06:58:08 AM UTC, original submission:  

Hi

I'm running Synology DS214play with Debian chroot. Inside chroot I have mounted the /homes filesystem where my 800GB data is, and /volumeUSB2 device, where I have WD Passport 1TB external drive. I'm attempting to backup 800GBs to 1TB drive.

I use DSM 5.2, and inside of Debian chroot I've installed rdiff-backup.

I run it like this:

diff-backup --exclude-symbolic-links -v5 /home/wkoszek rdiff-backup.20151013

root@wkoszek_nas:/mnt/volumeUSB2# mount
proc on /proc type proc (rw,relatime)
sys on /sys type sysfs (rw,relatime)
none on /dev type devtmpfs (rw,nosuid,noexec,relatime,size=355860k,nr_inodes=88965,mode=755)
none on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)
/dev/mapper/vg1000-lv on /home type ext4 (rw,relatime,user_xattr,synoacl,barrier=0,journal_checksum,data=writeback,jqfmt=vfsv0,usrjquota=aquota.user,grpjquota=aquota.group)
/dev/sdt1 on /mnt/volumeUSB2 type vfat (rw,relatime,uid=1024,gid=100,fmask=0000,dmask=0000,allow_utime=0022,codepage=default,iocharset=default,shortname=mixed,quiet,utf8,flush,errors=remount-ro)

I get Invalid argument failure, since rdiff-backup doesn't like the filename. Attached are the details.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #35193:  rdiff_backup.log added by None (4KiB - application/octet-stream - Info on filenames causing problems)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by ericzolf (Posted a comment)
  • -email is unavailable- added by davekempe (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2020-02-24 ericzolf StatusPostponed => Duplicate
        Open/ClosedOpen => Closed
    2016-02-12 davekempe Severity3 - Normal => 2 - Minor
        StatusNone => Postponed
    2015-10-14 None Attached File- => Added rdiff_backup.log, #35193

    Back to the top


    Powered by Savane 3.5