bugLinterna Mágica - Bugs: bug #39726, LM stops working on Youtube and...

 
 

bug #39726: LM stops working on Youtube and Vimeo for Firefox23

Submitted by:  None
Submitted on:  Thu Aug 8 07:18:26 2013  
 
Category: NoneSeverity: 3 - Normal
Item Group: NoneStatus: Fixed
Privacy: PublicAssigned to: Ivaylo Valkov <valkov>
Open/Closed: ClosedRelease: None

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Sat Sep 7 09:44:12 2013, comment #14:

Hi,

It turned out I can set the http link to the Vimeo clip instead of the index page. Now the http link in the message about mixed content will send you to the clip.

This is now as fixes as possible. I'm closing the thicket. Re-open it or submit a new one if there are more issues.

The project switched from SVN to Git, so if you are building manually, check the website for information about the new repository.

Ivaylo Valkov <valkov>
Project AdministratorIn charge of this item.
Sat Aug 31 10:05:41 2013, comment #13:

Hi,

I can confirm the reported behavior on Vimeo. Unfortunately there is nothing I can do. The index page at Vimeo alway redirects to HTTPS. [1] The rest of the pages work fine. It is working with the The Toggle Mixed Active Content addon.

I'm considering this fixed then?

[1]
wget -S http://vimeo.com/
--2013-08-31 12:59:58-- http://vimeo.com/
Resolving vimeo.com (vimeo.com)... 74.113.233.128
Connecting to vimeo.com (vimeo.com)|74.113.233.128|:80... connected.
HTTP request sent, awaiting response...
HTTP/1.1 301 Moved Permanently
Server: Apache
X-Powered-By: PHP/5.4.14
Expires: Fri, 30 Aug 2013 22:00:17 GMT
Vary: User-Agent,Accept-Encoding
Location: https://vimeo.com/

Ivaylo Valkov <valkov>
Project AdministratorIn charge of this item.
Thu Aug 29 17:22:24 2013, comment #12:

Hi,

Tested rev418 on Vimeo. The third option (view the page without encryption) apparently doesn't work. Clicked it, the page reloaded but get the same notification instead of video in http.

The other two options open the appropriate links as expected.

Thanks for the work!

Anonymous
Wed Aug 28 20:33:05 2013, comment #11:

Hi,

Thanks for the link to the addon. I've implemented the third option (see attached file). There is a link to the Mozilla blog article, the addon and a link to the clip over HTTP. The fix is in revision 417.

Please test it and report back any issues.

Thanks.

(file #28949)

Ivaylo Valkov <valkov>
Project AdministratorIn charge of this item.
Sat Aug 24 22:55:01 2013, comment #10:

Hi,

I think the third option (adding a notification) is probably best as it probably involves less work and would let the user knows that LM is not broken.

I also found this
https://addons.mozilla.org/en-us/firefox/addon/toggle-mixed-active-content/

So if you are browsing youtube you can just turn the blocker off for your whole Youtube session so you don't have to unblock/reload everytime you try to watch another video.

Thanks for looking into the issue.

Anonymous
Tue Aug 20 19:48:26 2013, comment #9:

Hi,

I can confirm the issue. It is exactly as explained in the Mozilla blog article. The page is requested over HTTPS, but the video URLs are generated by the website as HTTP, hence they are being blocked. This is a blocker.

There are additional issues.

Linterna Mágica runs as a script inside the page without privilege access to the browser. The only way to detect this issue is to match the website URL against the extracted video URLs. Even when the issue is detected there is not much to do.

One option is to rewrite the video URLs to use HTTPS. This wont work - clips don't load. It is already tested. Even if it works, there is no guarantee that it will work everywhere.

The second option is to reload the page over HTTP. This will not be done as it is a security issue. It is not a good idea to decide instead the user how to visit the page.

A third option might be to inform the user and give him/her the choice to reload the page over HTTP or not watch the clip. This would probably have the effect of forcing a reload over HTTP, as most users would probably choose to visit the page over HTTP.

A fourth option would be a mix between three and two - add a config option to reload such pages over HTTP, which would be disabled by default. As a result of the default value the user would be warned and have the choice to manually reload.

I'm out of other ideas right now. Any comments?

Ivaylo Valkov <valkov>
Project AdministratorIn charge of this item.
Mon Aug 12 21:16:46 2013, comment #8:

Hi,

Thanks for reporting and providing so much information. Unfortunately I was a little bit preoccupied (and I still am) I couldn't respond in time. I'll read the Mozilla blog post and see if there is something I can do to fix things. Thanks again.

Ivaylo Valkov <valkov>
Project AdministratorIn charge of this item.
Sat Aug 10 19:32:57 2013, comment #7:

Hi,

Turned out this is the reason

https://blog.mozilla.org/tanvi/2013/04/10/mixed-content-blocking-enabled-in-firefox-23/

The script works now if disable block manually when the pages load.

Anonymous
Fri Aug 9 20:17:05 2013, comment #6:

Hi,

More update. The script works when the url is http but not when it is https for both vimeo and youtube. You can get the http version if you click the video from some third referring site such as google.

This happens only with Firefox 23.

Thanks

Anonymous
Fri Aug 9 11:20:50 2013, comment #5:

Just a comment as you say Vimeo is not working with VLC: Did you try my version of ViewTube as shown in issue 1 at Sebaro's page?
(http://userscripts.org/scripts/show/169665). This should work with VLC (and Totem) in Chromium also on Vimeo. You can give me a comment on the userscripts page.

Tobias Rupf <trupf>
Thu Aug 8 21:18:28 2013, comment #4:

Hi,

I think I have found a pattern.

Both Youtube and Vimeo videos work if I access it through a reference site say google (search the video in google first and then get to it through there) and they don't if I go to Vimeo or Youtube first and then play the video.

Sorry for the multiple posts, I don't mean to spam.

Anonymous
Thu Aug 8 21:03:54 2013, comment #3:

Ok, it stops working on Youtube again. Once again see "waiting for media plugin"

Anonymous
Thu Aug 8 20:10:17 2013, comment #2:

Hi,

Today mysteriously Youtube works again, it might have been a temporary glitch of the site

But still no luck with Vimeo, still get the "waiting for video plugin" error

Anonymous
Thu Aug 8 07:27:49 2013, comment #1:

Hi, can't upload the debug log
It says "upload size limit is set to 16384 kB, after insertion of the required escape characters." Try again with a different Youtube video (and rev 417)

https://www.youtube.com/watch?v=cWO3zKqm_KI

(file #28795, file #28796)

Anonymous
Thu Aug 8 07:18:26 2013, original submission:

Hi,

It seems that Firefox has changed something but somehow it only affects LM on two sites (as far as I know)

LM has stopped working on Youtube and Vimeo. Go to a random video on these sites and LM would load but stuck in "waiting for video plugin" if flash is enabled, there is just a blackbox otherwise.

Tested on other sites (dailymotion, ted.com, wimp.com) and they all work. I have tried using both totem and gecko-mplayer as the backend and the results are the same.

I have tested with both LM rev 415 and rev 417 with same results, the debug logs are from rev 415

The Youtube link used for the test https://www.youtube.com/watch?v=QAEkuVgt6Aw Vimeo is just the random video featured on the front page.

OS is Ubuntu, this apparently happens after upgrading to Firefox 23.On another partition with Fedora Firefox still at version 22 and both sites work fine just as it was in Ubuntu before the upgrade (aside from bug #39402)

Aditional info which may be helpful:

Viewtube has stopped working on Viemo and Youtube as well and only for FF23.

LM (and Viewtube) still works on Youtube on Chrome, (it never works on Vimeo anyway as Totem can't play vimeo and gecko-mediaplayer doesn't work in Chrome)

Smplayer's Youtube player still works.

Thanks a lot!

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #28949:  bug-39726.png added by valkov (38kB - image/png)
file #28795:  vimeo added by None (3kB - application/octet-stream)
file #28796:  youtube added by None (32kB - application/octet-stream)
file #28794:  vimeo added by None (3kB - application/octet-stream)
file #28792:  vimeo added by None (3kB - application/octet-stream)
file #28793:  youtube added by None (47kB - application/octet-stream)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by valkov (Posted a comment)
  • -unavailable- added by trupf (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 11 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sat Sep 7 09:44:12 2013valkovAssigned toNone=>valkov
      Open/ClosedOpen=>Closed
    Sat Aug 31 10:05:41 2013valkovStatusWorks For Me=>Fixed
    Wed Aug 28 20:33:05 2013valkovAttached File-=>Added bug-39726.png, #28949
      StatusConfirmed=>Works For Me
    Tue Aug 20 19:49:55 2013valkovStatusNone=>Confirmed
    Thu Aug 8 07:27:49 2013NoneAttached File-=>Added vimeo, #28795
      Attached File-=>Added youtube, #28796
    Thu Aug 8 07:19:41 2013NoneAttached File-=>Added vimeo, #28794
    Thu Aug 8 07:18:26 2013NoneAttached File-=>Added vimeo, #28792
      Attached File-=>Added youtube, #28793

    Back to the top


    Powered by Savane 3.1-cleanup1