bugCERTI - Bugs: bug #50421, Jcerti case cannot work

 
 

bug #50421: Jcerti case cannot work

Submitted by:  Lu Jinzhi <jinzhl>
Submitted on:  Tue 28 Feb 2017 12:42:03 PM UTC  
 
Category:  JavaCERTI Severity:  3 - Normal
Item Group:  Software error Status:  Invalid
Privacy:  Public Assigned to:  JbCh <jb_ch>
Open/Closed:  Open Release:  GIT-master
Reproducibility:  Once Fixed Release:  GIT-master

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Tue 19 Jun 2018 02:22:41 PM UTC, comment #9:

No feedback for a long time, considering this one as invalid for release 4.0.0.

We keep it for info.

JbCh <jb_ch>
Project AdministratorIn charge of this item.
Thu 02 Mar 2017 09:56:35 AM UTC, comment #8:

Hello,

Thanks for reporting, it can be very helpful for other certi/jcerti users to get such information.

As you are the first to describe such an issue using jcerti/certi, we will not apply a patch for now.

If you investigate a little more, please report it into this ticket. I just updated the status.

Many thanks,
regards,
Jb_Ch

JbCh <jb_ch>
Project AdministratorIn charge of this item.
Thu 02 Mar 2017 09:48:32 AM UTC, comment #7:

This problme has been fixed out.
In CertiRtiAmbassador.java, 141 line, code should be changed to
Process rtiaProcess = Runtime.getRuntime().exec("cmd /k start "+rtiaPathString + "rtia.exe -p " + serverSocket.getLocalPort());

I'm not sure if this problem caused by Java version. But I will move on to see

Lu Jinzhi <jinzhl>
Thu 02 Mar 2017 08:31:59 AM UTC, comment #6:

Hello, I update the CERTI3.5 and jCERTI from git. However, the code is blocked, in CertiRtiAmbassador, socket = serverSocket.accept();It cannot jump into next line. I attached rtig and rtia display. I also put .fed into the share folder.

This time it seems that Uav-send can get some data from rtig or rtia, but because socket is blocked, the code cannot jumped into nexet line to execute.

(file #39876)

Lu Jinzhi <jinzhl>
Tue 28 Feb 2017 08:42:33 PM UTC, comment #5:

Hello,

You are using a quit old version of jcerti.

I would recommend to use the current git trunk version for jcerti which is much more up to date and used in other project as ptolemy hla bridge.

Anoymous clone:

>> git clone git://git.savannah.nongnu.org/certi/jcerti.git


As well, the current and most used version of CERTI is 3.5.1.

Please try with up-to-date versions of both.

Best regards,
Jb_Ch

JbCh <jb_ch>
Project AdministratorIn charge of this item.
Tue 28 Feb 2017 06:49:20 PM UTC, comment #4:

In CertiRtiAmbassador.java,

try {
LOGGER.info("test ");
socket = serverSocket.accept();
LOGGER.info("test ");
messageBuffer = new MessageBuffer(socket.getInputStream(), socket.getOutputStream());
} catch (IOException exception) {
throw new RTIinternalError("Connection to RTIA failed. " + exception.getLocalizedMessage());
}

The code stop in socket = serverSocket.accept();So I don't know if how this happened.

By the way, before these code, I found a bug:
Process rtiaProcess = Runtime.getRuntime().exec("cmd "+rtiaPathString + " rtia -p " +
serverSocket.getLocalPort());
I think "cmd " should be added in front of the code, or it cannot work

Lu Jinzhi <jinzhl>
Tue 28 Feb 2017 03:36:04 PM UTC, comment #3:

PS, I think RTI Ambassador executable is created successfully, but socket between rtia and rti should be some problems. Socket is accepted and no reponse or there is something wrong in the repsonse.

Lu Jinzhi <jinzhl>
Tue 28 Feb 2017 01:32:53 PM UTC, comment #2:

hello,

1. My systesm is window 7 64 bit OS.
2. jcerti is 1.0 CERTI is 3.4.3
3. Yes I use the RTIG generated by CERTI 3.4.3 and run it while ant UAVSend-run.
4. No, I think the UAVSend-run stop at Get a link to the RTI. it may be Connection to RTIA failed. I think.
So I'm not sure if there is some tips for env variables? Iattached the environement variables

(file #39850)

Lu Jinzhi <jinzhl>
Tue 28 Feb 2017 01:17:27 PM UTC, comment #1:

Hello,

As discussed per email, your description of the issue is not complete enough unfortunately:

- Is it windows 7 or Windows xp? Is it a 32 bit or 64 bit OS?

- Which version of jcerti are you using?

- Which version of Certi are you using?

- Is the rtig running while trying to run "ant UAVSend-run" command?

- Does the fed file "/JCERTI_INSTALL_PATH/jcerti/src_test/certi/uav.fed" is accessible to the rtig? To be sure, you can copy it under "CERTI_INSTALL_PATH/share/federations"

Best regards,
Jb_Ch

JbCh <jb_ch>
Project AdministratorIn charge of this item.
Tue 28 Feb 2017 12:42:03 PM UTC, original submission:

Hello,

When I use jcerti to execute the UAV example in windows, it cannot work in the "1 Get a link to the RTI" when the cmd run into socket = serverSocket.accept(); And some info from streamlistener show 'ERTI' is not recognized as an internal or external command." I think my firework can work, because my ballird case in C++ CERTI can work in my computer. So I think maybe some confgurations may not be right? Coud I get some help about this tuturials or something?

Lu Jinzhi <jinzhl>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by jb_ch (Posted a comment)
  • -email is unavailable- added by jinzhl (Submitted the item)
  • -email is unavailable- added by jinzhl
  •  

     

     

    Follow 11 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-06-19 jb_ch StatusWorks For Me => Invalid
        Assigned toNone => jb_ch
    2017-03-02 jb_ch Severity5 - Blocker => 3 - Normal
        Item GroupAction request => Software error
        StatusNone => Works For Me
        ReleaseJ-1.0.0 => GIT-master
        ReproducibilityNone => Once
        Fixed ReleaseUnknown => GIT-master
    2017-03-02 jinzhl Attached File- => Added happmaoo-2017-03-02_092731.png, #39876
    2017-02-28 jinzhl Attached File- => Added happmaoo-2017-02-28_143223.png, #39850
    2017-02-28 jinzhl Carbon-Copy- => Added jean-baptiste.chaudron@isae.fr

    Back to the top


    Powered by Savane 3.4