bugCERTI - Bugs: bug #53620, Max OS Sierra and certi 4.0.0 :...

 
 

bug #53620: Max OS Sierra and certi 4.0.0 : problem with X11?

Submitted by:  None
Submitted on:  Thu 12 Apr 2018 08:37:25 AM UTC  
 
Category:  CERTI Severity:  3 - Normal
Item Group:  Compilation error Status:  Invalid
Privacy:  Public Assigned to:  JbCh <jb_ch>
Open/Closed:  Open Release:  GIT-master
Reproducibility:  Every Time Fixed Release:  None

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Fri 13 Apr 2018 11:20:37 AM UTC, comment #1:

This is not a bug in CERTI but it is (in my opinion) a bug or inconsistency in the X11 library used per the MAC Sierra.

To bypass this problem, you have to avoid linking with X11 which is used for billard and in this case you will use the billard nogui.

example command to force no X11:

>> cmake -DCMAKE_INSTALL_PREFIX=../install ../certi -DFORCE_NO_X11=ON


Set this bug as invalid but we have it now for documentation purpose for MAC users.

JbCh <jb_ch>
Project AdministratorIn charge of this item.
Thu 12 Apr 2018 08:37:25 AM UTC, original submission:

I still have a problem when installing certi 4.0.0 in macOS Sierra 10.12.6.

The solution proposed to bug #53592 worked well when using cmake:
cmake -DCMAKE_INSTALL_PREFIX=$PTII/vendors/certi400 $HOME/src/certi-4.0.0

But after doing "make" in $CERTI_SRC/build I had this error:

fatal error: too many errors emitted, stopping now [-ferror-limit=]
1 warning and 20 errors generated.
make[2]: *** [test/libgraphc/CMakeFiles/graph.dir/graph_c.cc.o] Error 1
make[1]: *** [test/libgraphc/CMakeFiles/graph.dir/all] Error 2
make: *** [all] Error 2

It seems to be a problem with X11. I'm using XQuartz 2.7.11 (xorg-server 1.18.4).

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by jb_ch (Posted a comment)
  •  

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-04-13 jb_ch StatusNone => Invalid
        Assigned toNone => jb_ch
        Fixed ReleaseGIT-master => None

    Back to the top


    Powered by Savane 3.4