buglwIP - A Lightweight TCP/IP stack - Bugs: bug #55744, memp_malloc: out of memory in pool...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #55744: memp_malloc: out of memory in pool TCP_PCB_LISTEN

Submitted by:  Allen Tseng <love2006806>
Submitted on:  Wed 20 Feb 2019 09:40:02 AM UTC  
 
Category:  TCP Severity:  3 - Normal
Item Group:  Crash Error Status:  Invalid
Privacy:  Public Assigned to:  None
Open/Closed:  Closed Planned Release:  None
lwIP version:  1.4.1

Wed 20 Feb 2019 11:09:35 AM UTC, comment #3:

Hi Simon

And the port A is into the listen state successful.
But port B can not into.

Allen

Allen Tseng <love2006806>
Wed 20 Feb 2019 10:52:07 AM UTC, comment #2:

Hi Simon
Thanks for your reply.

In my step.2 I call tcp_close() to close listen pcb and when the closed-state I call tcp_close() again to remove tcp_bound_pcb.
Is the step correct?
Or those operate are not completely to close listen pcb?
I'm first time to use lwip.

Allen

Allen Tseng <love2006806>
Wed 20 Feb 2019 09:43:36 AM UTC, comment #1:

No, not a bug. You're probably not closing the listen pcb before trying to reopen it.

Simon Goldschmidt <goldsimon>
Project Administrator
Wed 20 Feb 2019 09:40:02 AM UTC, original submission:

Hello
I'm not sure is this a bug.
I use raw api in non-os environment.
My application is TCP server.
The flow is below:
1.Create two raw socket server.(port A, port B)
First for data exchange, and a second socket for reopen the two socket.(Two socket port are different)

2.When port A connecting, other client connect port B.
Port B receive callback function will call close_conn() to close itself. And I will call close_conn to close port A.
After port A pcb->state was CLOSED, use tcp_close() to let port A and port B pcb->state to CLOSED from listen state and CLOSED again to remove tcp_bound_pcb.

3.Recreate two raw socket server.

Question is in step.3.
After create port A, when port B in listen function, it show the below message and lwip is not work.
message:
memp_malloc: out of memory in pool TCP_PCB_LISTEN

Please correct me if anything wrong.

Please help me, I really need to solve.
Thank you.

Allen Tseng <love2006806>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by goldsimon (Posted a comment)
  • -email is unavailable- added by love2006806 (Submitted the item)
  • -email is unavailable- added by love2006806
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-02-20 goldsimon StatusNone => Invalid
        Open/ClosedOpen => Closed
    2019-02-20 love2006806 Carbon-Copy- => Added -email is unavailable-

    Back to the top


    Powered by Savane 3.4