bugCERTI - Bugs: bug #59058, Use certi in 2017 standard

 
 

bug #59058: Use certi in 2017 standard

Submitted by:  Behnam <fonqri>
Submitted on:  Thu 03 Sep 2020 08:20:54 AM UTC  
 
Category:  CERTI Severity:  4 - Important
Item Group:  Compilation error Status:  Wont Fix
Privacy:  Public Assigned to:  JbCh <jb_ch>
Open/Closed:  Open Release:  GIT-master
Reproducibility:  None Fixed Release:  Unknown

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 04 Jan 2021 10:34:39 AM UTC, comment #1: 

Hello,

Thanks for reporting.

The main issue is that we HAVE TO comply with HLA standard which are currently defined with auto_ptr. The latest official HLA standard is HLA 1516 2010 Evolved.

We are looking forward the release of the new HLA which I believe will include unique_ptr and shared_ptr to comply with new C++14/C++17 standards.

For now, we can't apply any correction for this, you will have to use a different compiler or change your compilation options.

Best regards,
Jean-Baptiste

JbCh <jb_ch>
Project AdministratorIn charge of this item.
Thu 03 Sep 2020 08:20:54 AM UTC, original submission:  

Hi,
Because in interface classes you used  dynamic exception specifications and auto_ptr that are removed from standard in c++1z i can't use CERTI in c++ 2017 projects.
If you remove dynamic exception specifications and use unique_ptr instead of auto_ptr we can use CERTI in c++1z projects.
When i try to compile project with c++1z standard i get dynamic exception specification error

Behnam <fonqri>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by jb_ch (Posted a comment)
  • -email is unavailable- added by fonqri (Submitted the item)
  •  

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2021-01-04 jb_ch StatusNone => Wont Fix
        Assigned toNone => jb_ch

    Back to the top


    Powered by Savane 3.6