buglwIP - A Lightweight TCP/IP stack - Bugs: bug #63113, can lwip support GSO(generic...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #63113: can lwip support GSO(generic segment offload) feature?

Submitter:  jiangheng <jinag12345>
Submitted:  Tue 27 Sep 2022 12:16:38 PM UTC
   
 
Category:  TCP Severity:  3 - Normal
Item Group:  Feature Request Status:  Invalid
Privacy:  Public Assigned to:  goldsimon
Open/Closed:  Closed Planned Release:  None
lwIP version:  2.1.3

Tue 10 Oct 2023 08:40:54 PM UTC, comment #1: 

This is not a bug. We're using this bugtracker to keep track of outstanding bugs.

Aside from that, no, I don't have any suggestions as I haven't written GSO code before. I'd suggest to have a look at what Linux does, but then again, you cannot backport that stuff back to use due to license issues...

Simon Goldschmidt <goldsimon>
Group administrator
Tue 27 Sep 2022 12:16:38 PM UTC, original submission:  

 I am using lwip as a tcp stack based on dpdk, dpdk have GSO feature, require tcp stack support trasnport large tcp package( exceed MTU limit).

I want to modify the lwip to support the TSO feature. Do you have any suggestions?

jiangheng <jinag12345>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by goldsimon (Posted a comment)
  • -email is unavailable- added by jinag12345 (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2023-10-10 goldsimon StatusNone Invalid
        Assigned toNone goldsimon
        Open/ClosedOpen Closed

    Back to the top

    Powered by Savane 3.13-b921.
    Corresponding source code