buglwIP - A Lightweight TCP/IP stack - Bugs: bug #13337, O_NONBLOCK defined as decimal

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #13337: O_NONBLOCK defined as decimal

Submitted by:  Oleg Tyshev <olegreen>
Submitted on:  Wed 08 Jun 2005 02:16:25 PM UTC  
 
Category:  sockets/netconn Severity:  3 - Normal
Item Group:  None Status:  Wont Fix
Privacy:  Public Assigned to:  None
Open/Closed:  Closed Planned Release:  None
lwIP version:  None

Fri 17 Nov 2006 11:35:33 AM UTC, comment #2: 

Don't think it's a bug. See comments by jackie.

Christiaan Simons <christiaans>
Project Member
Wed 20 Jul 2005 07:16:35 AM UTC, comment #1: 

when a constant digit prifix with zero(0), it is an octal constant declaration, not a decimal.

04000U equal to 0x0800, it is not a bug.

jackie chang <ataikaman>
Wed 08 Jun 2005 02:16:25 PM UTC, original submission:  

In file sockets.c O_NONBLOCK is used as bit field:
    if (((flags & MSG_DONTWAIT) || (sock->flags & O_NONBLOCK))

but in file socket.h it is defined as decimal
#define O_NONBLOCK    04000U

I think it should be 0x4000

Oleg Tyshev <olegreen>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

CC list is empty

 

Do you think this task is very important?
If so, you can add your encouragement to it.
This task has 0 encouragements so far.

Only logged-in users can vote.

 

 

 

Follow 2 latest changes.

Date Changed by Updated Field Previous Value => Replaced by
2006-11-17 christiaans StatusNone => Wont Fix
    Open/ClosedOpen => Closed

Back to the top


Powered by Savane 3.5