buglwIP - A Lightweight TCP/IP stack - Bugs: bug #26185, Explicitly count the length of...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #26185: Explicitly count the length of seg->pbuf, instead of assuming it to be ONE

Submitted by:  Roy Lee <roylee17>
Submitted on:  Wed 15 Apr 2009 01:51:14 PM UTC  
 
Category:  TCP Severity:  3 - Normal
Item Group:  Faulty Behaviour Status:  Duplicate
Privacy:  Public Assigned to:  None
Open/Closed:  Closed Planned Release:  None
lwIP version:  CVS Head

Fri 17 Apr 2009 10:17:02 AM UTC, comment #3: 

Closing this as duplicate since Roy responded on lwip-devel: "Sure, thank you."

Simon Goldschmidt <goldsimon>
Project Administrator
Thu 16 Apr 2009 09:33:20 AM UTC, comment #2: 

Roy: can this now be resolved as a duplicate of bug #25094?  It seems like the patch you submitted there will address this as well.

Kieran Mansley <kieranm>
Project Member
Wed 15 Apr 2009 08:53:47 PM UTC, comment #1: 

Could you go into detail on this? Is it the same bug I discovered on bug #25094? If so, the solution for this should be as simple as making sure that tcp_connect only needs ONE pbuf?

Simon Goldschmidt <goldsimon>
Project Administrator
Wed 15 Apr 2009 01:51:14 PM UTC, original submission:  

Currently, tcp_connect()->tcp_enqueue() forms an two-pbuf segment, which
breaks the assumption in the SYN_SENT case clause of tcp_process().

Either the above assmuption should be removed, or the code flow of
tcp_connect() needs to be reviewed.

Roy Lee <roylee17>

 

Attached Files

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by kieranm (Posted a comment)
  • -email is unavailable- added by goldsimon (Posted a comment)
  • -email is unavailable- added by roylee17 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2009-04-17 goldsimon Open/ClosedOpen => Closed
    2009-04-17 goldsimon StatusNone => Duplicate
    2009-04-15 roylee17 Attached File- => Added 0001-Explicitly-count-the-length-of-seg-pbuf-instead-of.patch, #17921

    Back to the top


    Powered by Savane 3.5