buglwIP - A Lightweight TCP/IP stack - Bugs: bug #45085, pbuf_header fails in tcp_input on...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #45085: pbuf_header fails in tcp_input on rx pbuf from win32 pcap netif

Submitted by:  Wilfred <will>
Submitted on:  Tue 12 May 2015 04:37:47 PM UTC  
 
Category:  pbufs Severity:  3 - Normal
Item Group:  Faulty Behaviour Status:  Invalid
Privacy:  Public Assigned to:  None
Open/Closed:  Closed Planned Release:  None
lwIP version:  1.4.1

Fri 28 Aug 2015 08:08:03 PM UTC, comment #5: 

I had a few bugs in our porting layer and after fixing these bugs, I am no longer able to reproduce the asserts in lwIP. I think you can close #45085

Wilfred <will>
Wed 19 Aug 2015 08:53:17 PM UTC, comment #4: 

Give me a few days and I will try to reproduce the error. Is it OK if I send you additional information to your "gmx" email address?

Wilfred <will>
Wed 19 Aug 2015 08:18:17 AM UTC, comment #3: 

Could you somehow try to get a reproduction? Without any further information, I cannot tell you where the problem is.

Simon Goldschmidt <goldsimon>
Project Administrator
Wed 13 May 2015 03:43:26 AM UTC, comment #2: 

I am using the default values that were set in this file. The original values are shown below commented out. I also tried to increase the sizes (after receiving your email) as shown by the new values below, but I still get an assert.

//#define PBUF_POOL_SIZE          120
#define PBUF_POOL_SIZE          500

//#define PBUF_POOL_BUFSIZE       128
#define PBUF_POOL_BUFSIZE       1500

What's weird is that the application is still working after the assert. Could it be related to our application that may send large buffers (up to 8K) via one call to netconn_write as follows:
      err=netconn_write(ncon, data, len, NETCONN_COPY);

Wilfred <will>
Tue 12 May 2015 07:30:50 PM UTC, comment #1: 

I do have "network intensive" applications running with the pcap netif on windows. The assert suggests that you have a chained rx pbuf where the first pbuf doesn't provide enough room to hold the headers (ethernet, IP and TCP). What's your PBUF_POOL_BUFSIZE set to?

Simon Goldschmidt <goldsimon>
Project Administrator
Tue 12 May 2015 04:37:47 PM UTC, original submission:  

I get an assert in LwIP version 1.4.1 : pbuf.c: line 525. I am running LwIP on Windows ('win32' port) using the pcap driver.

The assert:
LWIP_ERROR("increment_magnitude <= p->len", (increment_magnitude <= p->len), return 1;);

The data:
increment_magnitude=20
p->len=0

The stack trace:
pbuf_header(pbuf * p, short header_size_increment)  Line 525 C
tcp_input(pbuf * p, netif * inp)  Line 116 + 0x1d bytes C
ip_input(pbuf * p, netif * inp)  Line 574 + 0xd bytes C
ethernet_input(pbuf * p, netif * netif)  Line 1363 + 0xd bytes C
tcpip_thread(void * arg)  Line 103 + 0x13 bytes C

I have ported a fairly network intensive application to the netconn API. Any ideas on why I get this assert?

Wilfred <will>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by gradator (Updated the item)
  • -email is unavailable- added by goldsimon (Posted a comment)
  • -email is unavailable- added by will (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-08-28 gradator StatusWorks For Me => Invalid
        Open/ClosedOpen => Closed
    2015-08-28 goldsimon StatusNeed Info => Works For Me
    2015-08-05 goldsimon StatusNone => Need Info
    2015-05-12 goldsimon SummaryAssert in V1.4.1 : pbuf.c: 525 => pbuf_header fails in tcp_input on rx pbuf from win32 pcap netif

    Back to the top


    Powered by Savane 3.5