buglwIP - A Lightweight TCP/IP stack - Bugs: bug #53789, Two "statement is...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #53789: Two "statement is unreachable" warning in ip6.c and icmp6.c.

Submitted by:  yanhc <yanhc>
Submitted on:  Mon 30 Apr 2018 02:52:40 AM UTC  
 
Category:  IPv6 Severity:  3 - Normal
Item Group:  Compiler Warning Status:  Invalid
Privacy:  Public Assigned to:  None
Open/Closed:  Closed Planned Release:  None
lwIP version:  2.0.2

Mon 30 Apr 2018 06:57:32 PM UTC, comment #1: 

Already fixed in git head, but thanks for reporting!

Dirk Ziegelmeier <dziegel>
Project Administrator
Mon 30 Apr 2018 02:52:40 AM UTC, original submission:  

In my MDK-ARM IDE, line 718 of ip6.c and line 121 of icmp6.c will cause the following warning:
\lwip-2.0.2\src\core\ipv6\icmp6.c(121): warning:  #111-D: statement is unreachable.

The ip6.c is as follows, the break is unreachable after goto:
    default:
      goto options_done;
      break;

The icmp6.c is as follows, the break is unreachable after retrn:
    return;
    break;

I have checked latest 2.0.3, the issue is still there.

yanhc <yanhc>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by dziegel (Posted a comment)
  • -email is unavailable- added by yanhc (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-04-30 dziegel StatusNone => Invalid
        Open/ClosedOpen => Closed

    Back to the top


    Powered by Savane 3.5