bugdavfs2 - Bugs: bug #63364, davfs2 1.7.0 mounts segfault when...

 
 

bug #63364: davfs2 1.7.0 mounts segfault when accessed with dolphin

Submitter:  None
Submitted:  Mon 14 Nov 2022 03:26:47 PM UTC
   
 
Category:  None Severity:  3 - Normal
Item Group:  None Status:  None
Privacy:  Public Assigned to:  None
Open/Closed:  Open
* Mandatory Fields

Add a New Comment Rich Markup
   

Wed 07 Dec 2022 03:44:03 PM UTC, comment #2: 

I can confirm this.

System: Arch Linux
Kernel: 6.0.9-arch1-1
File browser: nautilus 43.1-1

Someone else also mentioned this problem on AUR (Arch Linux User Repository) as well: https://aur.archlinux.org/packages/davfs2#comment-888885

Anonymous
Fri 18 Nov 2022 11:04:25 AM UTC, comment #1: 

I have the same problem with davfs 1.7.0
There is no problem with davfs2 1.6.1

System: opensuse tumbleweed
Kernel: 6.0.8-1
File Browser: nautilus 43.0-3.1

Best regards

Felix <alphalemmi>
Mon 14 Nov 2022 03:26:47 PM UTC, original submission:  

Since the update to 1.7.0 my davfs-mount crashes whenever I access it with dolphin file browser. Dolphin is still able to load the directory-content but after that I can't access any files or subdirectories after that.

Steps to reproduce
1. Mount a webdav folder with davfs-fuse
2. Access the folder with dolphin file manager
3. Try to open any file or subdirectory.

After the crash the terminal shows "transport endpoint not connected", dmesg reports a segfault:

[22463.946668] mount.davfs[28726]: segfault at 0 ip 00007f70d9b1176c sp 00007fffda724100 error 4 in libneon.so.27.5.4[7f70d9b0d000+16000]
[22463.946687] Code: 1e fa 41 57 41 56 41 55 41 54 55 89 f5 83 e5 01 53 48 89 fb f7 dd 66 81 e5 83 73 89 e8 48 83 ec 08 80 cc 40 83 e6 02 0f 45 e8 <0f> b6 07 84 c0 0f 84 d1 00 00 00 48 89 fa 45 31 e4 4c 8d 2d fc 3b
[22463.946756] audit: type=1701 audit(1668002619.496:2042): auid=1000 uid=1000 gid=90 ses=3 subj=unconfined pid=28726 comm="mount.davfs" exe="/usr/bin/mount.davfs" sig=11 res=1

I tried it with an completely blank folder so there is no strange file in it and it crashes nonetheless. This doesn't happen when accessing the mount with an alternative file manager like "Files".

My System
Linux version 5.15.76-1-MANJARO (builduser@fv-az214-469) (gcc (GCC) 12.2.0, GNU ld (GNU Binutils) 2.39.0) #1 SMP PREEMPT Sat Oct 29 14:22:16 UTC 2022
Dolphin 22.08.2
Operating System: Manjaro Linux
KDE Plasma Version: 5.26.2
KDE Frameworks Version: 5.99.0
Qt Version: 5.15.6
Kernel Version: 5.15.76-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-6700 CPU @ 3.40GHz
Memory: 62,7 GiB of RAM
Graphics Processor: NVIDIA GeForce GT 710/PCIe/SSE2

Please let me know what additional info I can provide to help you track down this bug.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by alphalemmi (Posted a comment)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

    No changes have been made to this item

    Back to the top

    Powered by Savane 3.13-4448.
    Corresponding source code