bugSpamAssassin Milter Plugin - Bugs: bug #20027, milter fails to find user settings...

 
 

bug #20027: milter fails to find user settings for long names, aliases

Submitted by:  Andrew Daviel <adaviel>
Submitted on:  Fri 01 Jun 2007 01:59:00 AM UTC  
 
Category: NoneSeverity: 3 - Normal
Item Group: NoneStatus: None
Privacy: PublicAssigned to: None
Open/Closed: Open

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Fri 01 Jun 2007 01:59:00 AM UTC, original submission:

If I have an alias such as "abuse: joe", or a long name
using sendmail MATCH_GECOS option, e.g. "Joe.User@example.com",
spamass-milter fails to find the user's settings when they are the only recipient.

I suspect that the same applies to virtual users etc.

Probably there is now way around this, since at the time
the milter is called aliases have not been expanded.
Unless it was able to read the aliases database (and /etc/passwd
for the MATCH_GECOS case)

Andrew Daviel <adaviel>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by adaviel (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    No Changes Have Been Made to This Item

    Back to the top


    Powered by Savane 3.1-cleanup