bugpyFormex - Bugs: bug #43480, Problems with method smooth...

 
 

bug #43480: Problems with method smooth between TriSurface and Mesh

Submitted by:  francesco <francio>
Submitted on:  Mon 27 Oct 2014 02:46:00 PM UTC  
 
Category:  Core Severity:  2 - Minor
Item Group:  Functionality error Status:  Wont Fix
Privacy:  Public Assigned to:  Benedict Verhegghe <bverheg>
Open/Closed:  Open

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 27 Oct 2014 03:30:44 PM UTC, comment #5:

TriSurface.smooth() could probably work with quad4. So, maybe, we could move it up to mesh.py and call it Mesh.surfacesmooth()?
This should once be tested.

gianluca de santis <gianlucadesi>
Project Member
Mon 27 Oct 2014 03:18:54 PM UTC, comment #4:

Perfect to me to make the Mesh.smooth method callable from TriSurface.smooth by using special arguments.

francesco <francio>
Project Member
Mon 27 Oct 2014 03:13:58 PM UTC, comment #3:

Move what outside what class?

This is the perfectly normal syntax: a derived class can overwrite a method of the parent class. If it does, you can call the method of the parent class using the class name.

If useful, we can make the Mesh.smooth method callable from TriSurface.smooth by using special arguments.

Benedict Verhegghe <bverheg>
Project AdministratorIn charge of this item.
Mon 27 Oct 2014 03:00:42 PM UTC, comment #2:

that is what I do but then why dont we move it outside the class?

francesco <francio>
Project Member
Mon 27 Oct 2014 02:54:25 PM UTC, comment #1:

You can call the Mesh smooth method on a TriSurface:

Mesh.smooth(mytrisurface,...)

Benedict Verhegghe <bverheg>
Project AdministratorIn charge of this item.
Mon 27 Oct 2014 02:46:00 PM UTC, original submission:

There are two different methods smooth in the classes trisurface and mesh.

The problem is :
I have a TriSurface, but I want to use the Mesh.smooth.
this is not possible as a smooth method is already defined in Trisurface.

TriSurface is a mesh instance so the toMesh() will return again a TriSurface. the only way is to transform it directly using Mesh(coords,elems).

so either
1 we rename the method,
2 redefine the toMesh in TriSurface to return a mesh class

francesco <francio>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by gianlucadesi (Posted a comment)
  • -email is unavailable- added by bverheg (Posted a comment)
  • -email is unavailable- added by francio (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 7 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-10-27 gianlucadesi Severity1 - Wish => 2 - Minor
        Item GroupFeature request => Functionality error
        StatusNone => Wont Fix
    2014-10-27 bverheg Severity2 - Minor => 1 - Wish
        Item GroupFunctionality error => Feature request
        StatusWont Fix => None
    2014-10-27 bverheg StatusNone => Wont Fix

    Back to the top


    Powered by Savane 3.4